Chord Platform - Degraded Service

Incident Report for Chord Commerce

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 21:30 UTC

Update

This incident has been resolved.
Posted Nov 18, 2025 - 21:30 UTC

Monitoring

Customers may experience issues when trying to access the Chord platform. This is an identified issue with a third-party service provider and is currently being resolved.
Posted Nov 18, 2025 - 13:31 UTC
This incident affected: Hub.