Infrastructure issue

Incident Report for Chord Commerce

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 06:48 UTC

Update

This incident has been resolved. Chord Hub is fully operational again. We apologize for the disruption. If you continue to experience issues, please contact support.
Posted Jul 07, 2026 - 06:45 UTC

Update

We are continuing to investigate this issue.
Posted Jul 07, 2026 - 04:23 UTC

Investigating

We are investigating an infrastructure issue impacting Chord AI
Posted Jul 07, 2026 - 04:22 UTC
This incident affected: Hub.