Chord Copilot Service Disruptions

Incident Report for Chord Commerce

Resolved

This incident has been resolved.
Posted May 18, 2026 - 15:30 UTC

Investigating

We are currently investigating an issue affecting Chord Copilot. Some users may experience errors. Our team is actively working to identify the cause. We will provide updates as more information becomes available.
Posted May 18, 2026 - 14:35 UTC
This incident affected: Hub.